SAP Knowledge Base Article - Public

3374934 - Error to access items from the Library after a refresh - Target System impacted

Symptom

After a refresh, an error pops up in Course Home, related to Cover Page.

Error:

Error message = Request processing failed; nested exception is java.lang.NullPointerException: Cannot invoke "com.plateausystems.elms.framework.coverpage.api.CoverPageVO.getLayout()" because "coverPageVO" is null

<br>Ticket No = 203255<br>ErrorFingerprint [exceptionRootCauseTag=385d59cf9deac63cba5ea4e059aa139d4e4233aa, exceptionStackTraceTag=0afbe04d37b9b1b0b95a6fb7537e5584f1fe1b91]<br>Timestamp = 2023-08-31T13:43:24.514+0000<br>Stack trace = java.lang.NullPointerException: Cannot invoke "com.plateausystems.elms.framework.coverpage.api.CoverPageVO.getLayout()" because "coverPageVO" is null

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Once the refresh is done, login in the target system.
  2. Navigate to the Learning Admin side.
  3. Find an item that was copied from Source that you know that uses cover page.
  4. Make sure this item is either assigned to a user or available in a library that the test user has access to.
  5. Now navigate to the user side.
  6. Try to access the item details page.
  7. The error will be prompted in the screen.

Cause

The cause of the issue is described below.

On b2305 an update to the refresh script was performed to not copy the cover page content from Source to Target. Due to this update, items that use cover page will be copied over to Target system, but its cover page won't.

Course Home will show a validation error as it was not able to find the cover page configuration.

To confirm whether the item is impacted by the refresh defect, please follow the steps below:

  1. Navigate to the impacted item >
  2. Open cover page and note that - despite being active there is no content populated (the root cause for the content to be missing is indeed the refresh defect).

Resolution

After a discussion between Engineering and Product Management, the following 2 solutions are available.

  1. Redo the refresh as a manual refresh (not via IRT) via a support ticket; or,
  2. Manually update the impacted item(s) cover page(s).

PS. Please note that SAP cannot provide a custom script to reapply the cover pages content from your source instance to your target instance.

Engineering and Operations teams already modified the Manual Refresh script since August 28th. Automated Refresh script (IRT) will be updated soon via a patch, which needs to be approved by Engineering.

Keywords

refresh, cover page error, course home error, because "coverPageVO" is null, coverPageVO, exceptionRootCauseTag=385d59cf9deac63cba5ea4e059aa139d4e4233aa, exceptionStackTraceTag=0afbe04d37b9b1b0b95a6fb7537e5584f1fe1b91, LRN-145260, KI2305 , KBA , LOD-SF-LMS-SER , Config. Consulting & Service Requests , Known Error

Product

SAP SuccessFactors Learning all versions