Symptom
You would like to setup a Workflow Rule to receive a notification for when a Service/Sales Quote is submitted to approval, however when filtering for "Release Status" as a condition in the creation of a new Workflow Rule using Quote as the Business Object, no values are displayed in the system.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Application and User Management Work Center.
- Go to the Workflow Rules View.
- Select New Button.
- In the Description field, enter a desired description.
- In the Business Object field, Select Quote.
- In the Timing field, enter On Ever Save.
- Select Next button.
- Select Add Group.
- In the dropdown, Select Release Status.
- In the Compare Operator field, Select Equal to.
- In the With field, Select Value.
- In the blank field, Select the dropdown arrow.
No records found are displayed in the UI.
Cause
The "Release Status" condition can be selected as a option when creating a new Workflow Rule using Quote as the Business Object, however the condition will not display any values as Sales/Service Quote do not have the status Not Released/ Released.
Resolution
The possible workaround for this scenario is the creation of an extension field in the Sales/Service Quote document that can be used as a condition in the Workflow Rules to trigger the notification for the business users, however it is important to note that the extension field in the Service/Sales Quote will require to be filled manually based on the parameter set in the Workflow rule after the Sales/Service Quote is submitted.
Keywords
sales quote, service quote, quote, workflow rule, release status, submit, approval, business object , KBA , AP-CQP-CQ , Customer Quote , AP-CQP , Customer Quote Processing , How To