Symptom
After finishing the content, when the acknowledgment is submitted or the content window is closed, SCORM content freezes/loading and displays a blank screen in an inline window.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
1. Enable Launch Inline content window for SCORM object.
2. After finishing the content, attempt to acknowledge or close the inline content window when you finish/reach the end of the content.
3. Content window freezes or loading with blank screen.
Cause
According to our engineering team's analysis, the issue lies with the SCORM content itself, as it functions correctly when the content loaded in a new window, and the completion pop-up is visible on the screen.
Resolution
Our engineering team has recommended that, contact the content vendor/provider to inquire about the action that is triggered when the "End Training" button is clicked on the content. There appears to be an issue with this when launching the content inline.
Workaround:
While checking with the content provider, we can request that launch the content in a new window, which should temporarily resolve the issue.
[Learning Administration> Content> Content Objects> Open the content object associated with an item> Select 'Launch Method'> Enable the setting 'Launch in a New Browser Window'> Apply Changes]
Keywords
Content freezes and loading, Inline window freezes , KBA , LOD-SF-LMS-CNT , Content , Problem