SAP Knowledge Base Article - Public

3377976 - E-Verify not triggered for rehires - Onboarding

Symptom

E-Verify not triggered for rehires.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

1. Go to Onboarding dashboard.
2. Select the rehire candidate.
3. Check that I9 section 2 signature is completed.
4. E-Verify is not triggered.

Cause

Based on the U.S. government’s upgraded guidelines, this is an expected behavior for rehires.

Resolution

For rehires with E-verify case within 3 years, the e-verify is not expected to trigger since they can still use their previous record. 

You can see the U.S. government’s upgraded guidelines here: https://www.e-verify.gov/e-verify-quick-reference-guide-for-employers-30-initial-verification-31-form-i-9-and-e-verify/312

At present, customers may rely on the information from the previous Form I-9 and, in the event no documents have expired, then they are instructed to not create a new E-Verify Case.

Employers have the option of treating all rehired employees as new hires by completing a new Form I-9 and creating a case in E-Verify. However, employers also have the option of completing Section B, Reverification and Rehire, for rehires and only completing a new Form I-9 and creating an E-Verify case upon rehiring employees for whom no previous E-Verify cases were created. 

If you rehire a former employee within three years of the initial execution of the previous Form I-9, but did not create an E-Verify case, or if you created a case and did not receive a result of employment authorized, have the employee complete a new Form I-9 and create a case in E-Verify.

If you rehire a former employee within three years of the date of the initial execution of the previous Form I-9, created a case from that Form I-9, and received a result of employment authorized, you may be able to rely on the information from the employee’s previous Form I-9. Follow the steps outlined below when rehiring an employee who previously had a case created in E-Verify and received an employment authorized result.

If the previously created E-Verify case received a result of employment authorized and the Form I-9 has:Then:
No expired documentsWrite the employee’s rehire date in Supplement B of the existing Form I-9. Do not create a new case in E-Verify.
or
Complete a new Form I-9 for the employee and create a new E-Verify case for the employee.
An expired:
  • U.S. passport or
  • U.S. passport card or
  • Permanent Resident Card or
  • Alien Registration Receipt Card (Form I-551)
  • List B document
Write the employee’s rehire date in Supplement B of the existing Form I-9. Do not create a case in E-Verify.
or
Complete a new Form I-9 for the employee and create a new E-Verify case for the employee.
An expired List A or List C document that triggers reverificationWrite the employee’s rehire date and the updated employment authorization document information in Supplement B of the existing Form I-9. Do not create a case in E-Verify.
or
Complete a new Form I-9 for the employee and create a new E-Verify case for the employee.

Keywords

E-verify, Rehires, E-verify rehires, Onboarding, ONB, OBX, Onboarding 2.0 , KBA , LOD-SF-OBX-EVF , Everify , Problem

Product

SAP SuccessFactors Onboarding 2305