SAP Knowledge Base Article - Public

3378364 - Email Address deleted in Onboarding still exists in Employee Profile after conversion - Onboarding

Symptom

  • The candidate has removed the Email Address field during the Personal Data Collection step. Yet, the email still exists in Employee Profile - Basic Information.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Cause

System is working as designed:

  • Email Address in the Basic Information in the EC Table will remain even after candidate deleted them during PDC step due to the standard HRIS sync mapping.

Resolution

The email field has a standard HRIS sync mapping from the emailInfo entity and since the field was available at one time, it has been synced to user entity. On deleting the email from PDC step, the contact information details have been cleared out, however the data synced into Users still persists.

  • The emailId there [Basic Information - Live Profile User Information] is the username field which was already synced to the Users entity.
  • The email field if populated in the Users entity for the candidate, the same value is loaded on Employee Profile in the header section.

In case the business requires this behavior to be changed, you may submit an enhancement request so the Product Team can review it and see if it can be considered for future roadmap.

Keywords

emailInfo, Live Profile User Information, Basic Information, Email Address, Onboardee, Users Entity, deleted email, Onboarding, ONB2.0, ONB, OBX , KBA , LOD-SF-OBX-EC , Integration EC - MPH, Hire , Problem

Product

SAP SuccessFactors Onboarding 2305