Symptom
- The candidate is unable to log in the instance due to the BizX link in the Rehire Welcome Message redirecting to the SSO login page.
Environment
- SAP SuccessFactors Onboarding
Reproducing the Issue
- As the Rehire candidate, click on the BizX link in the Rehire Welcome Message
- The page redirects to the SSO login page rather than the SF Login Page
- In Email Services > Email Status, search for the corresponding email that we was sent
- Click on the BizX link (also the Reset Password link)
- The page redirects to the SSO login page rather than the SF Login Page
Cause
- In the Rehire Welcome Message, the BizX URL has the old employment ID in place which has the login method as "SSO":
https://performancemanager.successfactors.com/login?company=XXXXXXXX&username=(OLD EMPLOYMENT ID)&pm_product_name=ONB
Verify the Login Method of the Old Employment ID in Reset User Passwords = "SSO" - Click on the link and it will redirect to the SSO login page.
Resolution
PERMANENT FIX:
- Engineering Team created an internal ticket for the permanent fix -- OBX-27716
WORKAROUND:
- Go to Manage Login Accounts
- Search for the affected candidate/user
- Change the username to (NEW EMPLOYMENT ID) and login type as PWD.
- Reset the password of the external user.
- Ask external user to login via:
https://performancemanager.successfactors.com/login?company=XXXXXXX&username=(NEW EMPLOYMENT ID)&pm_product_name=ONB
See Also
Keywords
Onboarding, Onboarding 2.0, OBX, Rehire, Rehire with Old Employment, ROOE, Reset Password, BizX, Rehire User Welcome Message, SSO, Login, OBX-27716, PWD , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem
Product
SAP SuccessFactors Onboarding 2305