Symptom
You would like to filter the Appointments date range from 01.08.2023 to 14.09.2023 as example, but nothing is appearing on the result list.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Log into the system and go to Activities work center.
2. Open the Appointments work center view and click on Advanced Search button.
3. Switch to "All" query.
4. Under "Start Date" field set to "01.08.2023 - 12:00am".
5. change also the "End Date/Time" field to "14.09.2023 - 12:00am".
6. Click on "GO" button.
7. No results are showing even you have records for this period.
Cause
The issue can be the criteria used on both fields.
Resolution
Check if the field criteria is "= Equal to" on both fields.
In case yes, change the "Start Date" field criteria to ">=Greater than or equal to" also change the criteria to "End Date/Time" field to "<= Less than or equal to".
Keywords
Date; Search; Advanced; Advanced Search; Not Working; Showing; Results; Blank , KBA , AP-RC-UIF-RT , UI Framework Runtime , How To