Symptom
- The background check status is "Request Submitted" while the integration status is "Completed with error".
- SOAP Fault - Code: soap:Server, Detail: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.NullReferenceException: Object reference not set to an instance of an object. at SuccessFactors.SubmitReleaseFull_SuccessFactors(SFRelease Release)
Environment
SAP SuccessFactors Recruiting Management
Cause
The vendor side was unable to process the request due to missing mandatory values in the background check request.
The error is specific to the integration which Destination Type is SOAP.
Resolution
Please obtain the error details from Integration Center -> Monitor Integration and consult the third-party vendor to resolve the issue using these details.
How to extract the SOAP request and response from Integration Center:
- Go to Integration Center -> My Integrations
- Edit the integration
- Open the Destination Settings tab.
- Check "Enable Diagnostic" and save the change.
- Initiate the background check request from the job application again.
- Go to Integration Center -> Monitor Integration to check the latest process log.
There would be an entry "Attached is raw data output as payload", and the request payload (.xml file) generated by integration would be attached with this log entry. The SOAP response is also getting logged in the event log (.csv file).
If further assistance is required from SAP Support, please raise a support ticket to SuccessFactors Recruiting with the product area LOD-SF-RCM-INT.
Keywords
RCM, background check, integration center, job application, error, failed, SOAP Fault , KBA , LOD-SF-RCM-BCI , Background Check , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem
SAP Knowledge Base Article - Public