Symptom
You cannot see the defined code list values for your custom fields in the UI.
Environment
- Service Cloud Version 2
- Sales Cloud Version 2
Reproducing the Issue
- Navigate to your user profile on the top-right corner of your screen, and from the dropdown list select Settings-> All Settings ->General and click Extensibility Administration
- Go to the service you want to create custom field for.
- Here,you create a custom field type String and field format Code
- Here you also create a list of code values
- Now you go to UI , select the service and choose adaptation
- Add the custom field in the UI and on selecting the dropdown you will notice the code values do not appear.
Cause
The defined values does not populates for the field in the UI is because in the Extensibility , you have set the Action as Active.
Resolution
The functionality is designed in such a way that the value for which you mark as Action as "Deactive" will only populate in the UI.
To set the value as Deactive, follow the below steps.
- Navigate to your user profile on the top-right corner of your screen, and from the dropdown list select Settings-> All Settings ->General and click Extensibility Administration
- Go to the service where you have created custom field
- Select the EDIT button on the row and open the field values
- In the Action column change the action type to "Deactive"
Keywords
KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , CEC-CRM-CZM , Customization for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0