Symptom
You cannot see the defined code list values for your custom fields in the UI.
Environment
- Service Cloud Version 2
- Sales Cloud Version 2
Reproducing the Issue
- Navigate to your user profile on the top-right corner of your screen, and from the dropdown list select Settings-> All Settings ->General and click Extensibility Administration
- Go to the service you want to create custom field for.
- Create a custom field type String and field format Code
- Create a list of code values
- Go to UI , select the service and choose adaptation
- Add the custom field in the UI and on selecting the dropdown you will notice the code values do not appear.
Cause
These values does not populates because in Extensibility the code values status are not set as <Active>.
Resolution
The functionality is designed in such a way that the UI only display the code value which has status 'Active'
To set the value as <Active>
- Navigate to your user profile on the top-right corner of your screen, and from the dropdown list select Settings-> All Settings ->General and click Extensibility Administration
- Go to the service where you have created custom field
- Select the EDIT button on the row and open the field values
- Click <Activate> button under the <Action> Column
Keywords
KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
SAP Knowledge Base Article - Public