SAP Knowledge Base Article - Public

3380040 - Customer Hub - Email from also shows the one defined for Case

Symptom

  • Email "From" Field displays both Case Object and General Object emails in Agent Desktop.
  • Customer's setup includes defined email addresses for 'case' and 'general' objects in email channels.
    • When confirming a customer in Agent Desktop, a business user can email the customer, but the 'From' field displays the 'Case' email as well.
    • Your expectation is to see only the email address set up for the 'General' object, not the case or any other e-mail channel that does not have the object type=General.

Environment

  • SAP Service Cloud V2
  • Agent Desktop

Reproducing the Issue

  1. Connect to the Agent Desktop
  2. Search for and confirm a business partner
  3. Go to E-mail and notice that e-mail defined for Case is also displayed as an option for outbound e-mails from (field)

Cause

  • All email channels appear in Agent Desktop because predicting users' context for outbound communication not feasible.
  • The system ensures visibility of all available channels for outbound emails due to this unpredictability.

Resolution

  • System operates as designed.
  • When an email is composed from agent desktop, the ‘From’ address should display all the active email channels configured in the system.
  • The same is true independently of the object type of such e-mail channels.
  • This display is independent of the object because predicting the user's specific email context is not possible.
  • Solution: Offer user training and guidance for effective channel selection based on context.

See Also

E-mail Channels

Keywords

Email channel, From, AD, Object Type , KBA , CEC-CRM-AD , Agent desktop - live channels , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0