SAP Knowledge Base Article - Public

3380716 - You are not able to delete Attachments in the Service Tickets

Symptom

You are not able to delete Attachments in the Service Tickets because delete button beside the attachments are grayed out

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Go to Service Work Center
  2. Navigate to Ticket Work Center View
  3. Select & Edit Ticket with completed status
  4. Navigate to Attachments Tab
  5. You can see Delete button is grayed out

Cause

When Ticket is in Completed Status you can still add attachments but it is not possible to delete attachments because attachments can have a information/process which required to resolve the ticket. 

Resolution

This is the expected system behavior.

If you still want to delete attachments , Change the Ticket status from "Completed" to "In process". 

Steps:

  1. Go to Service Work Center View
  2. Navigate to Ticket Work Center View
  3. Select & Edit Ticket with Completed status
  4. Go to Adaptation Mode
  5. Change Layout to General Tickets and Troubleshooting
  6. Navigate to Attachments Tab
  7. Change status from Completed to In process
  8. Save your Changes

Keywords

Delete attachments, Service tickets, Inprocess ,status, Completed. , KBA , SRD-CC-RUI-DOC , Document Service Reuse UI's , AP-RC-DOC , Document Centric Application Service , Problem

Product

SAP Cloud for Customer core applications all versions