Symptom
You are not able to delete Attachments in the Service Tickets because delete button beside the attachments are grayed out
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Service Work Center
- Navigate to Ticket Work Center View
- Select & Edit Ticket with completed status
- Navigate to Attachments Tab
- You can see Delete button is grayed out
Cause
When Ticket is in Completed Status you can still add attachments but it is not possible to delete attachments because attachments can have a information/process which required to resolve the ticket.
Resolution
This is the expected system behavior.
If you still want to delete attachments , Change the Ticket status from "Completed" to "In process".
Steps:
- Go to Service Work Center View
- Navigate to Ticket Work Center View
- Select & Edit Ticket with Completed status
- Go to Adaptation Mode
- Change Layout to General Tickets and Troubleshooting
- Navigate to Attachments Tab
- Change status from Completed to In process
- Save your Changes
Keywords
Delete attachments, Service tickets, Inprocess ,status, Completed. , KBA , SRD-CC-RUI-DOC , Document Service Reuse UI's , AP-RC-DOC , Document Centric Application Service , Problem