Symptom
You have noticed that, upon submitting an absence for an employee, a duplicate record has been created and system is allowing you to approve those records without throwing any errors.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors HXM Suite
Cause
- This is a known issue - Under specific conditions, it might occur that two absences are created in parallel for the same day when the requests come through different servers at the same time, where each of the process checks does not see the other request as it has not yet been persisted.
- As the collision check is done on absence creation, this overlap will not be checked again on approval.
Resolution
- Although there are various guardrails in place for this behavior to stop occurring, it cannot be detected in 100% of times, so in order to fix these inconsistencies, you can run the Check Tool 'There are no active employee time records that are duplicated.' under Time Off > Employee Time:
- Upon running this check, if the system encounter any duplicates, it will propose to you to cancel the duplicate records and give an option to export the results, which then you can Import, if there are too many duplicate records, by changing the status to 'Cancelled'. If only a couple of records are duplicated, you can cancel them manually through Manage Time Off Structures > Employee Time > externalCode;
- Support Engineers, please check internal memo.
See Also
Keywords
duplicate, employee time, duplicate records, duplicated leaves, time off, create absence, sf, employee central, ec, check tool, There are no active employee time records that are duplicated , KBA , LOD-SF-EC-TIM-UI , Team Absence Calender/ Workbench/ ESS UI's , LOD-SF-EC-TIM , Time Off , Problem