Symptom
When attempting to save an attachment in a Continuous Performance Management activity, receive an error message:
Your activity is created successfully but few of the attachments failed to upload. Would you like to upload the files again?
Environment
SAP SuccessFactors Continuous Performance Management
Reproducing the Issue
- Log in to system
- Navigate to Home dropdown > Continuous Performance Management
- Click Create Activity
- Populate Activity Name > Click Add to upload an attachment
- After attachment is loaded, select Save
- Receive error message
Cause
- Enable OpenText Integration setting is enabled in Provisioning when third-party provider is not being used
- Enable OpenText Integration setting is not enabled in Provisioning when third-party provider is being used
- SuccessFactors cannot connect to the third-party server
Resolution
I. Enable OpenText Integration setting is enabled in Provisioning when third-party provider is not being used
As a customer, you do not have access to Provisioning. Please engage a Certified Partner or SuccessFactors Product Support to implement the fix.
- Log into Provisioning
- Select Company Settings
- Search for Enable OpenText Integration (Requires "Enable the Attachment Manager", "Enable Generic Objects", and "Enable RBP") (Warning: this feature is for third-party storage provider integration only)
- Uncheck the box for the setting > Save Feature
- Enter Company ID
II. Enable OpenText Integration setting is not enabled in Provisioning when third-party provider is being used
As a customer, you do not have access to Provisioning. Please engage a Certified Partner or SuccessFactors Product Support to implement the fix.
- Log into Provisioning
- Select Company Settings
- Search for Enable OpenText Integration (Requires "Enable the Attachment Manager", "Enable Generic Objects", and "Enable RBP") (Warning: this feature is for third-party storage provider integration only)
- Check the box for the setting > Save Feature
- Enter Company ID
III. SuccessFactors cannot connect to the third-party server
Third party issues cannot be addressed by SuccessFactors Product Support, and instead the third-party vendor will need to be contacted to view the connection to their server.
If your third-party provider is OpenText, please open a case under component XX-PART-OPT-ECM-CLD.
See Also
2518360 - Document Management Service and the Manage Documents tool - SAP SuccessFactors
Implementing Document Management and Attachment Storage - Enabling Document Management
Keywords
success factors, SF, SFSF, CPM, third party, third parties, document upload attachment upload, content servers, activities, documents, attachments, Enable OpenText Integration , KBA , LOD-SF-PLT-DOC , Document Management , LOD-SF-CPM-ADM , Admin Center, RBP. Permissions and Settings , LOD-SF-CPM-ACT , Activities , Problem