Symptom
In AskHR, you've created categories and subcategories. In computer browser, the list of categories and subcategories is correct. But in AskHR using a mobile device, order of subcategories is misplaced/ not followed.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Employee Central
- Ask HR - Employee Central Service Center (ECSC)
- Employee Central
Reproducing the Issue
- Login in to SFSF Employee Central Mobile App
- Click on AskHR icon.
- Click on "create ticket."
- Selecting Request category, you will notice category/sub-category order is not followed according to the configuration.
In the below image you can see that, subcategory is being misplaced in Mobile version.
Cause
This is standard behavior for AskHR Mobile. This is "by design" for mobile ask HR, we show the category-by-category creation order, not alphabetic order.
Resolution
Fix has been provided in 2311 release. Issue has been fixed.
See Also
Keywords
AskHR, Ask HR, Mobile, AskHR Mobile, ECSC, category, sub-category, order, misplaced, request category, sort, alphabetical order, category by category, disorder, create ticket, Service Center. , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Product Enhancement