Symptom
Inbound e-mails fail or bounced with message - 'Too many recipients (Process allows only 1 recipient)'
Environment
SAP Cloud for Customer core applications
Cause
Same e-mail address maintained for multiple e-mail channels in C4C system (Even if you set a channel as inactive, this does not stop inbound E-mails from being received on that deactivated channel. That is why the undeliverable e-mail messages errors refer to usage of more than 1 recipient).
OR
You have 2 routing rules at your email server, one forwarding emails sent to B2B and another sending it to B2C. Then the same email will be processed twice leading to this error.
Resolution
This is the correct behavior. Unfortunately is not possible to set one email channel to work as B2B and B2C at the same time. Using the same email address for multiple channels (Whether it be for B2B/B2C/Employee Support Type) is not recommended. This can cause confusion in terms of which channel configuration to be used when an email comes into the system. Moreover, changing the configuration at a later point would also be tricky.
Therefore, to avoid such scenario, customer should not be using the same email address for multiple channels.
See Also
Keywords
SCOT, Backend, Inbound E-mail , KBA , LOD-CRM-SC-EML , Email , LOD-CRM-SRP , Service Request Processing , How To
SAP Knowledge Base Article - Public