SAP Knowledge Base Article - Public

3382742 - Skills Portlet Does Not Display Ratings Depending on Language Selected

Symptom

When reviewing the Skills Profile block on People Profile, employees can see ratings in one language but not others.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Job Profile Builder
  • SAP SuccessFactors People Profile

Reproducing the Issue

  1. Login to SuccessFactors as an employee who has a sample default locale of French
  2. Navigate to Home dropdown > My Employee File
  3. Navigate to the Skill portlet and the employee can see ratings
  4. In the upper right-hand corner, select your profile picture > Settings
  5. Select Change Language > select a different language (i.e. English) > Switch
  6. Navigate back to Home dropdown > My Employee File
  7. Navigate to the Skill portlet and the employee can no longer see the same ratings

Cause

Expected behavior where ratings will be shown in the language of the user who provided the rating

Resolution

The Skill Profile block is no longer being maintained and will be sunset in the future. As a result, changes will not be made to this functionality.

Workaround:

Change the language to the same language as the user who provided the ratings.

Keywords

Skill Portlet, Skill Profile, success factors, SF, SFSF, JPB, portlets, pods, skills, employee profile, profiles, blocks, translations, languages, locales, rated, ratings, WSM-23395 , KBA , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , LOD-SF-EP-UI , People Profile UI (PP3 UI) , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

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