SAP Knowledge Base Article - Public

3382833 - Unable to Add Mashup to Custom Tab

Symptom

Unable to add mashup to custom tab.

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Go to the Menu.
  2. Open the desired view (e.g Accounts).
  3. Search and open any record.
  4. Start Adaptation.
  5. Edit the tabs.
  6. Add a new tab.
  7. Click on Apply.
  8. Edit the tabs and click in the arrow ">" for the affected tab.
  9. You will see the message "No Data. Looks like there are no options available for you to configure" and you don't find a way to add a mashup.

Cause

The steps to add a tab and to add a mashup are different.

Resolution

  1. Go to the Menu.
  2. Open the desired view (e.g Accounts).
  3. Search and open one record.
  4. Start Adaptation.
  5. Select the desired layout.
  6. In case you did not create a tab yet then it needs to be created.
  7. Hover over the tabs available.
  8. You should see a pencil button. Click on it.
  9. "Edit tabs" pop up will appear. Click on + to create a new tab.
  10. Give it a name and click on Apply.
  11. Navigate to the new tab you created.
  12. Hover the mouse in the empty content below the tab.
  13. You should see a pencil button. Click on it.
  14. A pop up "Configure tab" will be displayed.
  15. Click on > for Add mashup.
  16. Search the mashup and click on > for the mashup you want.
  17. Edit properties pop up will appear.
  18. Click on Apply.
  19. Click on End Session to end adaptation.

See Also

Help documentation: Add Mashups as Tabs

Keywords

Add Mashup, Tab, No Data, Adaptation , KBA , CEC-CRM-MAS , Mashups for SAP Sales/Service Cloud , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0