Symptom
Unable to add mashup to custom tab.
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Go to the Menu.
- Open the desired view (e.g Accounts).
- Search and open any record.
- Start Adaptation.
- Edit the tabs.
- Add a new tab.
- Click on Apply.
- Edit the tabs and click in the arrow ">" for the affected tab.
- You will see the message "No Data. Looks like there are no options available for you to configure" and you don't find a way to add a mashup.
Cause
The steps to add a tab and to add a mashup are different.
Resolution
- Go to the Menu.
- Open the desired view (e.g Accounts).
- Search and open one record.
- Start Adaptation.
- Select the desired layout.
- In case you did not create a tab yet then it needs to be created.
- Hover over the tabs available.
- You should see a pencil button. Click on it.
- "Edit tabs" pop up will appear. Click on + to create a new tab.
- Give it a name and click on Apply.
- Navigate to the new tab you created.
- Hover the mouse in the empty content below the tab.
- You should see a pencil button. Click on it.
- A pop up "Configure tab" will be displayed.
- Click on > for Add mashup.
- Search the mashup and click on > for the mashup you want.
- Edit properties pop up will appear.
- Click on Apply.
- Click on End Session to end adaptation.
See Also
Help documentation: Add Mashups as Tabs
Keywords
Add Mashup, Tab, No Data, Adaptation , KBA , CEC-CRM-MAS , Mashups for SAP Sales/Service Cloud , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0