SAP Knowledge Base Article - Public

3383829 - Employee Import error "The user is purged from database"

Symptom

When trying to change a username of a user, the system throws the error below:
"The user is purged from database. If you want to create a new user with the username, please first use the user ID in the brackets to permanently purge the user through Admin Center > Data Retention Management > System Identifier Purge"

Environment

SAP SuccessFactors HCM Suite

Cause

There is a user ID in the database associated with this username that has not been permanently purged.

Resolution

  • Search for the username of the user being imported on Data Inspector > Table_USERS_SYSINFO. If there are results, it means the user there is a userID still associated to that username in the database.
  • Before you use this username again, you will need to proceed with hard / permanent purge of this record. For this, you can refer SAP KBA 2392076 - System Identifier Purge - User Permanent or Hard Purge

See Also

  • KBA 2392076 - System Identifier Purge - User Permanent or Hard Purge
  • KBA 3375924 - How To check User Status Via Data inspector
  • KBA 2392094 - Re-activate a Purged User Via Employee Import Feature

Keywords

system identifier purge, import issues, importing, employee import, associates, duplicate username, bizX, purge, SuccessFactors, Platform, Data Inspector, user purge, Hard purge, Table_USERS_SYSINFO, Permanent purge , KBA , LOD-SF-PLT-UIM , Employee Import Issues , LOD-SF-PLT-DRM , Data Retention Management , How To

Product

SAP SuccessFactors HCM Suite 2511