Symptom
When you try to create a Sales Quote via Webservice ManageCustomerQuoteIn, the creation fails with error "No authorization for 'InterfacePattern <default> SAVE' on instance 'ABC' of 'BONodeProxy'" (Where ABC Represents the ID of the Instance).
Environment
SAP Business ByDesign
Reproducing the Issue
- Run the Payload for Sales Quote creation on the ManageCustomerQuoteIn interface.
- The creation fails with an error that follows this pattern:
<SeverityCode>3</SeverityCode>
<Note>RBAM: No authorization for 'InterfacePattern <default> SAVE' on instance 'ABC' of 'BONodeProxy <default>
Cause
This error can happen when the Sales Unit is not specified in the payload. The system is unable to create the document due to this missing information.
Resolution
You need to include the information about the Sales Unit in the payload sent to the ManageCustomerQuoteIn interface.
This is a sample snippet of how the information needs to be included:
<SalesUnitParty>
<PartyID>DEF</PartyID>
</SalesUnitParty>
Where DEF represents the ID of the Sales Unit.
Keywords
Sales Quote, Creation, Error, Web Service, Webservice, Failed, Payload, Response , KBA , AP-CQP-CQ , Customer Quote , How To