SAP Knowledge Base Article - Public

3385680 - Mashup not rendering in UI even after adding in the Trusted Domain List

Symptom

You have created a Mashup in the System and even added that URL in the Trusted Domain List, but still you are seeing the error : "Refused to connect".

Environment

  • SAP Sales Cloud V2
  • SAP Service Cloud V2

Reproducing the Issue

  1. Click on the profile button and go to Settings.
  2. Go to All settings and enter Mashup Authoring view.
  3. Click on create button and fill required data.
  4. In the URL field, paste your URL (e.g https://www.test.com/) and add them in the Trusted Domain List.
  5. Click on preview.
  6. Result: You will see the error: Refused to connect

Cause

Problem could be with the adapted URL because we are loading mashup through iframe and the provided URL should support the same.

Resolution

You can use below mentioned web page to test an URL if it works in an iframe or not.

http://iframe.projects.vincemitchell.me/  or https://www.w3schools.com/tags/tryit.asp?filename=tryhtml_iframe

In the URL field enter the entire mashup URL then click on update iframe.

Note: If URL is not supported in iframe, contact URL provider to support their application within iframe.

Keywords

KBA , CEC-CRM-MAS , Mashups for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions