Symptom
A mashup was created to open the Success Factor system on the user profile, however the User ID field is not available to be selected under your mashup binding parameter settings.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Service then Tickets TI screen as example.
2. Open any ticket.
3. Open the facet which the mashup was added.
4. The mashup is not opening with the customer profile.
P.S.: Ticket's TI screen is being used for this scenario, however this can be used for other screens.
Cause
1. The field needed as binding parameter is not available in the Tickets TI.
2. The field wanted as binding parameter is not available under the mashup settings to be selected.
Resolution
1. The field wanted to be used, for example "UserID", must exist in either port binding parameters list or Tickets TI.
2. If the field "UserID" is not available under Parameter Binding, then a KUT field can be created to store the Success Factor User ID, so the new KUT field can be used on binding parameter.
See Also
Also check which URL is passing when opening the mashup.
1. Go to Service then Tickets TI screen as example.
2. Open any ticket.
3. With the Chrome opened, press F12 on the keyboard to open the Chrome Dev Tools.
4. Open the facet with the mashup.
5. Go to Chrome Dev Tools, go to network tab and check the URL.
6. Check if the URL is picking the values as parameter.
Keywords
Mashup; Parameter; Field; Missing; URL; Profile; User , KBA , AP-RC-GEN-MSH , Mashups , How To
SAP Knowledge Base Article - Public