Symptom
- When trying to edit the portlet of an MDF object for a user; OR
- When trying to submit a workflow request; OR
- When trying to delete Job Profile Draft, receive an error:
"You cannot make any more changes to the record until your pending workflow requests have been approved or rejected. Reach out to the workflow approver to take appropriate action."
Environment
- SAP SuccessFactors Metadata Framework
- SAP SuccessFactors Job Profile
Reproducing the Issue
- Log in to system
- Navigate to the Action Search > enter a user's name > click the user's name
- Navigate to the portlet of the MDF object > Select the pencil icon to edit
- Receive error
OR
- Log in to system
- Navigate to Admin Center > Manage Data
- Make changes to any object with a workflow > Save
- Receive error
OR
- Log in to system
- Navigate to Home dropdown > Employee Profile
- Make updates to a portlet > Save
- Receive error
OR
- Log in to system
- Navigate to Admin Center > Manage Data
- Select Job Profile Draft > Take Action > Delete
- Receive error
Cause
- An initial record is in a Pending workflow
- Multiple workflow requests have been submitted for consecutive start dates
- Job Profile Draft in SalesDemo environments ONLY - Engineering deleted the workflow
- When checking the workflow, status is 'SENTBACK' --> this means the workflow still has a Pending status
- There is a field (e.g A) in the custom portlet that is filled with a string value, and other fields have rules set up that are dependent of the field (A). In the rules set up in the other fields, the field (A) value is parsed as a number, so that calculations can be made using it. While parsing the field (A) value, it identifies a string, so it cannot be parsed as a number.
Resolution
- The workflow approver will need to approve the workflow. The approver can be identified by following the steps in Implementing and Managing Workflows - Managing Workflow Requests as Admin.
- If there are no pending workflows for a user, MDF has provided a self service tool which is available through the Check Tool. Ensure that you have access to the check tool and have the required permissions to run checks from Metadata Framework (MDF) > MDF Records with Workflow Issues - Implementing the Metadata Framework (MDF) - Workflows in MDF
If the above step did not fix the problem then please create a case with Product Support under component LOD-SF-MDF-WFL so engineering can run a script.
- Job Profile Draft in SalesDemo environments ONLY
Please create a case with Product Support under component LOD-SF-TIH-MIG so engineering can run a script to fix the Check Tool error. The following details will be required to process the script:
- Pictures showing all JDM and JPB Check Tool errors have been resolved
- Data Center (URL of your login screen):
- Company Instance ID (where to apply changes):
- Approval - 'SENTBACK' status still counts as "Pending". Workflow will only count as completed if it has one of the following statuses: 'COMPLETED', 'CANCELLED" or 'REJECTED'.
- For Benefit Employee Claim, the request status on Benefit Overview Page and Claim History will remain as "IN PROCESS" until the workflow is 'COMPLETED', 'CANCELLED" or 'REJECTED'.
- Ensure the value of the field (A) is a numeric value, rather than a string e.g. instead of the value ‘10 days’, make sure it’s just ‘10’.
See Also
- 2544336 - Custom MDF workflow and its behavior depending on Pending Data = Yes/ No.
- Managing Workflow Requests as Admin
- Implementing and Managing Workflows - Managing Workflow Requests as Admin
- Implementing the Metadata Framework (MDF) - Workflows in MDF
Keywords
workflow, pending workflows, workflow MDF object, MDF, success factors, sf, sfsf, success factors, objects, tih, deletion, corrections, edits, modifying, errors, INC7913302,request status sentback, sent back, pending workflow requests error, Benefit Employee Claim workflow, claim in process. , KBA , LOD-SF-MDF-WFL , Custom Object based Workflows , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , LOD-SF-EC-GBF , Global Benefits , Problem