Symptom
- Category 41 To-Do Tasks (Complete Task for External Integration) are visible on the To-Do Panel.
- Category 41 To-Do task named ~Complete Task for External Integration~ (under product area Intelligent Services) are not being displayed/listed on the To-do panel but we can see it when querying the task via oData API (aka TodoEntryV2).
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Add a task on the Category 41 To-Do Tasks via oData API.
- Login to your SF instance.
- Check the To-Do Panel from the right side on the Home Page and notice that the added Category 41 To-Do task is not being displayed.
Cause
- Intelligent Services tile is set to hidden in Manage Home Page > Show/Hide To-Do Tiles.
- Show/Hide To-Do Tiles is not visible anymore on Manage Home Page, therefore, there is no current way to enable this on the instance.
Resolution
If you wish to make the Category 41 To-Do task visible on the To-Do Panel, we now offer a self-service option in the Check Tool, allowing you to manually remove the show/hide configuration data.
- Go to Check Tool.
- Click the Migration Tab.
- On the Search Filter, select Home Page for Application and "to-do visibility" for the Title.
- Of all the Checks results, please select Legacy to-do visibility settings are cleaned up. (LegacyTodoTileVisibility).
- On the right panel, the Results shows the to-do tiles which are set as hidden by customer.
- Should you wish to display these to-do tiles on your to-do panel again, click Quick Fix. This action will remove the show/hide configuration in legacy homepage so all supported tiles ( todo categories) will be visible on the to-do panel.
To‑Do Panel Hidden When Latest Shell Bar Experience Is Enabled
If the latest experience for the SAP shell bar is enabled, the To‑Do panel/icon will not appear in the header as documented in Changes Included in the SAP User Experience Updates | SAP Help Portal
This is because the To‑Do panel is being deprecated as it no longer aligns with SAP’s latest user experience standards.
See Deprecation of To-Do Panel | SAP Help Portal for more details on the deprecation.
How to Check Whether the Latest Shell Bar Experience Is Enabled
- Go to Company System and Logo Settings.
- Search for Enable the latest SAP shell bar.
- If this is checked, the To-Do Panel will NOT be displayed on the header / shell bar.
- If this is unchecked, the To-Do Panel will be displayed.
See Also
- SAP Help Portal - Managing Home Page
- SAP Help Portal - Where To-Do Tasks Are Shown
- SAP Help Portal - Using the Check Tool to Solve Issues
- SAP Help Portal - Changes Included in the SAP User Experience Updates
- SAP Help Portal - Deprecation of To-Do Panel
Keywords
, KBA , LOD-SF-PLT-TOD , To-Do List Issues , Problem
Product
Attachments
| Pasted image.png |
| Pasted image.png |
SAP Knowledge Base Article - Public