Symptom
You notice that a Contract has not triggered automatic renewal after the conditions in the Renewal Rule have been met. Checking the BTM Task of the Renewal, you see error "Organization Contracting Unit ID ABC must have organizational role Customer Service on DD.MM.YYYY" (Where ABC Represents the Contracting Unit ID).
Environment
SAP Business ByDesign
Reproducing the Issue
Checking the Contract:
- Go to the Sales Orders work center.
- Select the Contacts view.
- Show all contracts and find DEF (Where DEF represents the ID of the Customer Contract).
- Click on Edit.
- Navigate to the General tab.
- Select the the Renewal and Cancellation subtab.
Here you can see that the renewal rule is maintained and the renewal should have happened, but it was not triggered.
Checking the BTM Task, we can see the underlying error:
- Go to the Application and User Management work center.
- Select the Business Task Management view.
- Show all tasks and search for DEF (The ID of the Contract).
- Click on the Automated Task icon on Task 'Automatic Renewal of Contract DEF'.
- In the 'Automatic Renewal of Contract DEF', open the latest Application Log by clicking on it's ID.
Error "Organization Contracting Unit ID ABC must have organizational role Customer Service on DD.MM.YYYY" is displayed.
Cause
The error happens because the Organizational Unit used in the Contract does not have the relevant function activated at date DD.MM.YYYY as indicated in the error message.
Resolution
In order to solve this error, you will need to maintain the data specified in the error message:
- Go to the Organizational Management Work Center.
- Go to Edit Org Structure View.
- Find the relevant Organizational Unit.
- Configure the missing role to be active within the date shown in the error.
- Save and activate this change for the Organizational Unit.
Keywords
Contract, Role, Org Unit, Defined, Renewal, Renewed, Failed, Didn't Renew, Triggered, Renewal Rule, Customer Contract , KBA , SRD-CRM-ORD , Orders & Contracts , How To