Symptom
When trying to convert a Lead to an Account using the option Convert Lead to Corporate/Private Account, the error message "Save Failed" is displayed in the UI.
Environment
SAP Business ByDesign
Reproducing the Issue
1. Go to the Marketing Work Center.
2. Select New Lead in the Common Task.
3. Select Address Details.
4. Fill the following mandatory fields:
- Name.
- Country/Region.
- House Number/Street.
- City/State/ZIP.
6. Fill the Description field.
7. In the Account field, click on the New button.
8. Select Convert to Corporate Account.
9. In the New Window, click Save.
The Error Message "Save failed" will be displayed in the UI.
The same behavior occurs when the Convert to Private Account is selected.
Cause
The Address Details are required to be saved to the Lead before the Convert to Corporate/Private Account option is selected in the UI because the data information for the Lead is only stored in the backend after the save action is performed in the system.
Resolution
In order to convert a Lead without an account it is required that the Address Details are maintained and that Lead was Saved at least once.
Following are the correct steps to be performed in order to Convert to a Lead to an Corporate/Private Account:
1. Go to the Marketing Work Center.
2. Select New Lead Common Task.
3. Select Address Details.
4. Fill the following mandatory fields:
- Name.
- Country/Region.
- House Number/Street.
- City/State/ZIP.
6. Fill the Description field.
7. Select Save.
8. Open the Lead again.
7. In the Account field, click New button.
8. Select Convert to Corporate Account.
9. In the New Window, click Save.
All the address data will be transferred to the Newly created Account.
See Also
Please kindly check the following Help Portal documentation for further information regarding the creation of Leads in the system:
Keywords
lead, create, save failed, corporate account, private account, account, convert to corporate account, convert to private account, new , KBA , SRD-CRM-MKT , Marketing , How To