Symptom
When trying to open a quote or add a discount value on quote, we get error "Sorry for the inconvenience, but there seems to be an error in the system. An automatic notification has been sent our way and we'll be fixing the error as soon as possible. In the meantime, you can go back to the login page and continue working in SAP CPQ.".
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Login to CPQ
- Open any quote
- Try to add discount under discount field
- We get error.
Cause
- This issue could be caused because on the User page, the default number format was selected as 1.234,56, but the discount values were formatted in 1,234.56.
- Input string was not in a correct format (user number format).
Resolution
Please change the 'Number format' to appropriate one on the User page.
Kindly refer the below link for more information:
Keywords
Unable to add discounts, unable to open quote, Error, number format, user page, , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions