SAP Knowledge Base Article - Public

3386969 - Anonymous Contact Creation in SAP Marketing Cloud When Update Lead From C4C

Symptom

After updating a lead from C4C to SAP Marketing Cloud (SMC), the Lead is removed from actual contact and anonymous contact is getting created with lead details.

Environment

SAP Marketing Cloud

SAP Cloud for Customer 

Reproducing the Issue

In C4C:

  1. Go to the Sales work center.
  2. Go to the Leads work view.
  3. Search and open the Lead ID 1234 created via SMC replication (1234 means Lead ID).
  4. Perform a change in the Lead and save it.
  5. Check the Lead is replicated to SMC without the InternalContactID in the payload.

In SMC:

  1. SMC receives Lead from C4C, it is getting tagged to correct contact.
  2. The Lead is removed from actual contact and anonymous contact is getting created with lead details.

Cause

For this scenario, we can have the following root causes:

  1. The ID Mapping for Integration is not created for the Contact.
  2. The Communication Arrangement "ID Mapping Replication to SAP Business Suite".
  3. Under the Communication Arrangement "ID Mapping Replication to SAP Business Suite", the services are not correctly defined.
  4. The Communication Arrangement filter for business partner with status "In Preparation" is not defined.

Due to that, no Business Partner replication message get triggered for the prospect contact or the ID mapping of the contact not correctly generated.

Resolution

In order to resolve the issue

  1. Make sure the ID Mapping for Integration is correctly defined.
  2. Make sure that, according to the SAP Help Guide Configure Communication Arrangements | SAP Help Portal the Communication Arrangement "ID Mapping Replication to SAP Business Suite" has the service:
    • Replicate ID Mapping to SAP Business Suite - Unselect
    • Replicate Business Partner ID Mapping to SAP Business Suite - Select
  3. Make sure to add the Communication filter is set in order to send business partner with status “In Preparation” to SAP Marketing Cloud as per Filter Communication Arrangements | SAP Help Portal.

Keywords

Anonymous, Contact, Lead, InternalContactID, SMC, Marketing Cloud, C4C, Lead Replication , KBA , CEC-MKT-INT-CSL , SAP Marketing Integration with Cloud Sales , LOD-CRM-INT-YCM , Integration of C4C with Commerce , How To

Product

SAP S/4HANA Cloud 2308