Symptom
Error "You can't use business partner XXXXX because its status is 'Not Active'" appears when you try to open an Opportunity or Lead of an obsolete Account, but it doesn't appear when you open an Activity document.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Customers Workcenter.
- Go to an obsolete Account.
- Go to Opportunities or Leads facet and open an document.
- The error message "You can't use business partner XXXXX because its status is 'Not Active'" will appear.
- Now, go back to the same Account.
- Navigate to Activities facet.
- Open any document.
- There is no error.
Cause
The current system behavior involves the display of an error message when opening a Lead or Opportunity document, while no such message is shown when opening an Activity document. This behavior is not the result of any configuration settings.
Resolution
This is the current expected behavior of SAP Cloud for Customer.
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
- If you are a customer:
Contact your Account Executive. Check the link https://www.sap.com/services/innovation.html#contact-us.
An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.
Keywords
KBA , LOD-CRM-ACT , Activities , How To