Symptom
Layout adaptations made to Service category pane in tickets TI does not apply to logged in users layout.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open services > tickets TI
- Enter adaptation mode and choose required layout
- Open OVS for any field on the Service Category pane
- make change, for example, to set service category column as not visible
- Login with user assigned to this layout
- Navigate to open any ticket
- Open OVS for the field where the change was made
- See the service category column is visible still
Cause
The Service category pane and its fields are in a separate BO, meaning the layout assignment for tickets to a business role will not apply to this pane.
Resolution
For the layout changes to be applied to the service category pane and fields,
The layout assignment must be done for the business object "Service Category Catalog".
- Enter adaptation mode
- select layouts tab in adaptation pane
- Click the "Assign Layouts" button
- select "Service Category Catalog" option from Business Object drop down
- assign the correct layout to the required business role
Keywords
Service category, Incident Category, Cause Category, Resolution Category, Visible, Tickets , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem
Product
SAP Cloud for Customer core applications 2308