SAP Knowledge Base Article - Public

3387940 - SAP Marketing - Attribute 'Count of Interactions' in Segmentation Model does not fetch Contacts with Zero Interactions

Symptom

When trying to segment contacts that have no interactions using the "Count of Interactions" attribute with "Equal to 0" or "Less than 1" conditions, segmentation model always show 0 contacts in the segment count.

Environment

SAP Marketing Cloud

Cause

To calculate the Count of Interactions attribute, the system performs a join between the CUAND_CE_IC_ROOT (Contacts) table and the CUAND_CE_IA_RT (Interactions) table. Due to the nature of SQL join operations, records can only be matched when a common key exists in both tables. In this case, the join is performed using the Contact Key.

If a contact has no associated interactions, there are no corresponding records in the CUAND_CE_IA_RT table containing that contact key. As a result, the contact is not included in the joined dataset used to calculate the interaction count.

Therefore, contacts with zero interactions cannot be retrieved using the Count of Interactions attribute. The minimum value that can be selected for this attribute is 1.

Resolution

It is possible to identify contacts with no interactions by creating a segment using the Count of Interactions attribute and defining the condition Greater Than 0. When saving the segment, enable the Exclude option.

This approach creates a segment containing all contacts except those with one or more interactions. As a result, the segment effectively represents contacts that have zero interactions.

Keywords

KBA , CEC-MKT-SEG , Segmentation , CEC-MKT-DM-IC , Interaction Contact , CEC-MKT-DM-IA , Interaction , Problem

Product

SAP S/4HANA Cloud 2308