SAP Knowledge Base Article - Public

3388159 - The Responsible Employee Does Not Receive Customer Contract Notification

Symptom

You have approved a customer contract, ideally system should create a notification task to the responsible employee, but the user does not get it in his inbox.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Application and User Management work center.
  2. Go to the Business Task Management view.
  3. Search the contract ID and you find the notification "Customer Contract ABC Approved ". (ABC represents the ID of the contract), this notification is cancelled status.

From application log, you see the task determination information as following:

Business task is inconsistent - no valid responsible person/organization
Employee:XYZ (XYZ represents the ID of the responsible employee)
Info: Work Center Views that potentially grant access:
View:CRM_CONTRACTS_SALES
No employee has sufficient access rights

Cause

The user ABC does not has access right to view CRM_CONTRACTS_SALES, so the notification task is not sent and cancelled after some time.

Resolution

Ensure the user has access to CRM_CONTRACTS_SALES. 

Keywords

BTM; notification; not received; No employee has sufficient access rights; CRM_CONTRACTS_SALES. , KBA , SRD-CRM-SEO , Service Orders , Problem

Product

SAP Business ByDesign 2308