Symptom
The users have to click multiple time on add product for keyboard to appear in mobile UI.
Environment
SAP Cloud for Customer.
Reproducing the Issue
1.Click on add product while creating an order.
2.Click on the product field to start writing product id or description.
3.The keyboard does not show up and we just see a screen to select product.
4.Once you click on the product field again the keyboard is visible.
Cause
This is an expected behavior.
Resolution
1.This is an expected behavior and there is an idea submitted to enhance this feature.
Improvement Request Details - Customer Influence (sap.com)
2.As a work around Disable the company setting "Enable Value Help Suggestion in Phone". This will not show the suggestion popup (blank screen popup) and the user will be able to access the keyboard with a single click on the OVS field. But in that case the user will not be able to see suggestions while typing in the input field because the suggestion popup provides that functionality.
Keywords
Keyboard,C4C,Mobile,C4C mobile app , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , Problem