SAP Knowledge Base Article - Public

3388429 - Sales Order Item Cancellation Not Reflecting in Customer Demand

Symptom

Sales Order item is cancelled in Sales Order, but the line not cancelled in Customer Demand

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Sales Orders work center
  2. Choose Sales Orders view
  3. Search the relevant Sales Order ID and edit
  4. Navigate Items tab
  5. Find the line item YY and maintained Reason for Rejection (Ex: "Other Reason")
  6. Go to Outbound Logistics Control work center
  7. Choose Customer Demand view
  8. Select relevant Customer Demand id and Click on Edit
  9. Navigate the item tab and select line item YY is not cancelled, the delivery block status is equal to Blocked

Cause

Whenever a rejection occurs with a reason or a change in quantity in the sales order line item, approval will be requested. Approval for the changes made in the sales order is necessary. The system will then consider the changes in the sales order.

Resolution

To approve the changes made in the Sales Order, please follow these steps.

  1. Go to Sales order work center.
  2. Choose Sales Orders view.
  3. Search the relevant  Sales order id and edit.
  4. Navigate items tab.
  5. Maintain the reason for rejection and save it.
  6. Select the line item and choose the submit button and Choose submit for approval.
  7. Then the Sales Order ID status will change.

Keywords

How Sales Order item is cancelled in Sales Order, Reason for Rejection, submit for approval , KBA , AP-SDM , Supply and Demand Matching , Problem

Product

SAP Business ByDesign all versions