Symptom
You have added Customer part number field in product master data but it is not visible in the sales order items tab.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Order work center.
- View: Sales Orders.
- Show: All orders.
- Search and edit ABC (ABC represents Sales Order ID).
- Navigate to Items tab.
Cause
This is system standard behavior, as the Customer Part Number field is not available as a standard field.
Resolution
You have to create Extension field for Customer Part Number field in sales order items tab.
Choose the Calculation rule: Product ID (ProductBuyerID - ItemProduct)
Please refer to help documents which brief creation and adding extension fields.
See Also
Extension Fields Quick guide: https://help.sap.com/docs/SAP_BUSINESS_BYDESIGN/2754875d2d2a403f95e58a41a9c7d6de/b532137d13184adfbd4d08b4210628d2.html?q=create%20extension%20field
Create Extension field: https://help.sap.com/docs/SAP_BUSINESS_BYDESIGN/2754875d2d2a403f95e58a41a9c7d6de/2d8c90ce722d1014acc581aad621df2e.html?q=create%20extension%20field
Relevant KBA: 3345375 - Customer Part Number Not Showing In Documents
1733731 - The Customer Part Number is not Displayed in the Product Description of the Form
3220672 - Customer Part Number is not mapped on the XML that is sent to the Outbound Delivery Form
Keywords
Customer Part Number, Sales Order, Account, Items, Product, Extension Field , KBA , AP-SLO-SO , Sales Order , Problem