Symptom
Employee has no view permission for a certain background information block, but he can view background information through a shared Employee Profile domain report.
Environment
SAP SuccessFactors Employee Central
- Employee Profile
Reproducing the Issue
1. Log into instance.
2. Proxy as the employee himself >> go to Employee Profile >> confirm that he is NOT able to view one certain background information block and its information.
3. Proxy as the employee himself >> go to Report center >> open a shared Employee Profile domain report >> confirm that he is Able to view the certain background's information.
Cause
In Provisioning, the option "Enable Field Level Permission for data model elements (in all Sub domain schemas)" & "Enable Cell Level Permission for data model elements (in all Sub domain schemas)" are NOT enabled.
Resolution
According to the official handbook:
- Employee Profile Only means that field/cell level permissions are applied only for the EP schema.
- All Sub Domain Schemas means that field and cell level permissions are applied when the EP fields appear in other schemas, such as opening the Performance Schema and seeing User Information that is coming from EP.
- We recommend you enable All Sub Domain Schemas.
It is advised to enable the option "Enable Field Level Permission for data model elements (in all Sub domain schemas)" & "Enable Cell Level Permission for data model elements (in all Sub domain schemas)" in Provisioning, then the issue should be resolved.
Keywords
Field Level Permission, cell Level Permission, all Sub Domain Schema , KBA , LOD-SF-EP-REP , Ad Hoc Report (Employee Profile) , Problem