SAP Knowledge Base Article - Public

3389343 - Unable to Add Target Amount for Contracts Created via the Web Service

Symptom

You are unable to find and add Target Amount via the ManageCustomerContractin webservice in contract.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Application and User Management work center.
  2. View: Input and Output management.
  3. Sub-view: Service Explorer.
  4. Download WSDL for ManageCustomerContractIn webservice.
  5. Open the WSDL in a API testing software.
  6. You can see that Target amount is not available in the request.

Cause

Target Amount is currently not part of the ManageCustomerContractIn web service.

Hence, this is is the expected system behavior.

Resolution

This is a new requirement.

You can directly submit your request for an additional feature to the correct decision makers at SAP via Customer Influencer. The Customer Influence site for SAP Business ByDesign, allows customers to log Improvement Requests themselves and have the ability to work directly with our technology and development group.

Customer Influence allows you:

  • To search for existing ideas
  • To vote for ideas
  • To subscribe to ideas
  • To create new ideas

Keywords

Contract; Target Amount; Webservice; ManageCustomerContractIn , KBA , AP-CCP , Customer Contract Processing , Problem

Product

SAP Business ByDesign 2308 ; SAP Business ByDesign 2311