Symptom
Account Merge has triggered Sales Order update to ECC after the Order was completed which created a new order in ECC.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales > Sales Order;
- Open the affected Sales Order;
- Go to Changes facet;
- You noticed the order was processed some time ago but still it has triggered an update to ECC again;
- The account merge happened, hence the sales order was reassigned to the merged account.
Cause
The scoping question "Business Partner Merge of Completed Documents" is maintained active inside your business configuration.
Resolution
If you would like that completed documents remain untouched during merge process, then please de-scope the question "Business Partner Merge of Completed Documents" inside your business configuration. Otherwise, even completed documents will be changed and sent to ERP.
Keywords
sales orders, document, trigger, reparenting , KBA , LOD-LE-CQP-CO , Lean Sales Orders , Problem