Symptom
Multiple Users send Email from same ticket at same time
Environment
SAP Cloud for Customer
Reproducing the Issue
- 2 Users logged into C4C system
- Both Users open same Ticket around the same time
- If both Users try to edit the same Ticket the second User will get a Locking Object Error message which is expected
- If both Users try to send an Email from the same Ticket at the same time no Error is observed and Mails can be sent
Cause
When a second user edits the same Ticket it is recognized that the Ticket is already in Edit mode by another User and therefore throws up the Locking Object however when creating a new Email Edit mode is not recognized so no error is observed by the Second User.
Resolution
Standard Behavior. Email is not designed to recognize Edit mode so cannot determine how many mails are being sent from the same Ticket.
Keywords
Edit mode, Locking Object, Multiple Users, Email, Ticket , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SC-EML , Email , Problem