SAP Knowledge Base Article - Public

3390637 - Badge Count Not Correct in SAP Business ByDesign Mobile App

Symptom

Badge count is not correct in SAP Business ByDesign Mobile App

Environment

SAP Business ByDesign 

Reproducing the Issue

  1. Log into mobile device (Android/IOS)
  2. Badge count for SAP Business ByDesign Mobile App is there on the display screen of device
  3. Go to SAP Business ByDesign Mobile App ,no new tasks found in App

Cause

The issue is due to Cache and Background App Refresh is not enabled.

Resolution

You need to clear the mobile app cache and enable the app background refresh option.

  • IOS: iPhones don’t have a straightforward option to clear the app cache, the only way forward is to delete the app and reinstall it when needed.

     How to enable background app refresh for SAP Business ByDesign App?

  1. Go to Settings
  2. Go to General
  3. Search for Background App refresh
  4. Turn it on 
  5. Enable it for SAP Business ByDesign App
  • Android: How to clear cache?
  1. Go to Settings
  2. Search for Apps
  3. Select the App
  4. Go to Storage
  5. Choose Clear cache

    How to enable background app refresh for SAP Business ByDesign App?

  1. Open Settings, then tap Connections
  2. Select Data usage
  3. Scroll down to the Mobile section and tap Mobile data usage
  4. Select the SAP Business ByDesign App from below the usage graph
  5. Turn on Allow background data usage

See Also

3251587 - Frequently Asked Questions on ByD Mobile APPs

KB0654417 - How To Enable Push Notifications for SAP Business ByDesign Mobile App 

Help Document: https://help.sap.com/docs/SAP_BUSINESS_BYDESIGN/2754875d2d2a403f95e58a41a9c7d6de/c2b8fa5cd62c43949816853d4c303572.html?version=2108

Keywords

Badge count, background app refresh, App, notification, notifications, IOS, Android, bydesign, mobile, time, push, release, you have released, , KBA , SRD-CC-MOB , Mobile Framework , Problem

Product

SAP Business ByDesign all versions