Symptom
- Deleting Proxy Assignments for Inactive Users with Proxy Import ending with "error: user not in proxy's domain".
- As a SuccessFactors administrator I want to clear proxy rights for a user who is inactive however the proxy import is failing "error: user not in proxy's domain" received via email.
- I tried following 3236380 - Bulk Deleting Proxy Assignments for Inactive Users with Proxy Import but unable to remove the proxy assignment for an inactive user.
Environment
SAP SuccessFactors HCM suite
Reproducing the Issue
- Login via support access
- Go to “employee export” to download UDF.
- See that inactive users have proxy assignments.
- Go to Proxy Import.
- Download Template.
- Place “YES” in “REMOVE ALL” along with the other proxy details for these inactive users.
- Perform the import and email generated with "error: user not in proxy's domain".
Cause
Cause #1
The assignments done through Employee Import overwrite the assignments done in Proxy Management/Proxy Import. We recommend using only one of these methods to keep everything updated. See KBA: 2704750 - Missing proxy permission | Employee Import resetting proxy assignments - BizX Platform. Check also 2087319 - Proxy Management: How to Grant Proxy Access to Multiple Users with the Employee Import - BizX Platform
Cause #2:
1. when removing inactive user, system following the same process as adding new proxy, the operation owner need to have the permission to do so, say user A want to import proxy assignment allow B proxy as C, then A must have permission to proxy management with target population including B and C
2. since either A, B or C is inactive, the checking permission failed, so it will report a such error that use is not in admin domain
Resolution
Cause #1:
If you would like to process with deleting inactive proxy assignments via proxy import, then proxy assignments in the UDF should be cleared, and the proxy column in the UDF disabled.
However, please note once this is done, there is currently no other log or report that can be generated which will detail inactive proxy assignments, as can be seen in the UDF. Therefore, as mentioned in the above KBA, we recommend using only one of these methods (Proxy Import or Employee Import) to keep proxy assignments updated.
Cause #2:
Ensure to submit a proxy import from an admin user who has everyone access for proxy management permission, this will bypass the check. In other words, in order to remove proxy from an inactive user, you need to have the permission for proxy management and the target population has to be set to everyone. Otherwise, the proxy import tool won't be able to analyze the proxy relationship and it would fail with "user not in proxy's domain".
See Also
- 2087319 - Proxy Management: How to Grant Proxy Access to Multiple Users with the Employee Import - BizX Platform
- 3236380 - Bulk Deleting Proxy Assignments for Inactive Users with Proxy Import - SAP for Me
- 2704750 - Missing proxy permission | Employee Import resetting proxy assignments - BizX Platform
- 2087311 - Proxy Management - BizX Platform
- 2524310 - How to Grant Proxy Permission using Proxy Import?
- Help portal guide: Deleting Proxy Assignments for Inactive Users with Proxy Import
- Help portal guide: Setting Up and Managing Proxy Access
- Help portal guide: Creating, Editing, or Deleting Proxy Assignments with an Import File
Keywords
SuccessFactors, Proxy, Proxy Import, Employee Import, Deleting Proxy Assignments for Inactive Users with Proxy Import, UDF, Error, User not in proxy’s domain. , KBA , LOD-SF-PLT-PRX , Proxy , Problem