Symptom
Cannot set a service write access as No access (e.g sap.crm.service.userService or sap.crm.service.roleService).
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Click on the profile icon.
- Select Settings.
- Go to All settings.
- Open Business Roles view.
- Open any admin role.
- In business service section for "sap.crm.service.userService" or "sap.crm.service.roleService" try to set write access as No access.
- Result: It will return to Unrestricted.
Cause
For Admin business roles we provide few default services, some of them are: "sap.crm.service.userService", "sap.crm.service.roleService", "sap.crm.service.homepageService", "sap.crm.service.adminService", "sap.crm.service.searchService", "sap.crm.service.builtinSupportService", "sap.crm.service.i18nService" and "sap.crm.service.endUserFeedbackService".
Resolution
Any change made to such services will have no impact and will be assigned back with the default unrestricted access.
Keywords
Role, Users, Service, Unrestricted, Write Access, No Access , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , Problem