SAP Knowledge Base Article - Public

3391142 - Cannot Set Write Access as No Access for Some Services

Symptom

Cannot set a service write access as No access (e.g sap.crm.service.userService or sap.crm.service.roleService).

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Click on the profile icon.
  2. Select Settings.
  3. Go to All settings.
  4. Open Business Roles view.
  5. Open any admin role.
  6. In business service section for "sap.crm.service.userService" or "sap.crm.service.roleService"  try to set write access as No access.
  7. Result: It will return to Unrestricted.

Cause

For Admin business roles we provide few default services, some of them are: "sap.crm.service.userService", "sap.crm.service.roleService", "sap.crm.service.homepageService", "sap.crm.service.adminService", "sap.crm.service.searchService", "sap.crm.service.builtinSupportService", "sap.crm.service.i18nService" and "sap.crm.service.endUserFeedbackService".

Resolution

 Any change made to such services will have no impact and will be assigned back with the default unrestricted access.

Keywords

Role, Users, Service, Unrestricted, Write Access, No Access , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0