Symptom
You are using the sales quote volume - extended report and you have noticed that for some of the Account Contacts, the e-mail address is not showing, but rather showing the hashtag (#).
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics work center.
- Select the Design Reports view.
- Search for Report Sales Quote Volume - Extended.
- Click Edit.
- Execute the report.
- Navigate to the View tab.
- Click on the Add Fields to Row icon (+).
- Expand the Account - Contact.
- Select the checkbox for E-mail.
You see that for some of the contacts, the e-mail is not showing as expected.
Cause
The reason the e-mail address is not showing in the report is because the e-mail address is maintained under the Business Communication and not in the Personal Communication.
For the e-mail address to show or be retrieved to the report, the e-mail address needs to be maintained in the Personal Communication section.
Resolution
This is the system expected behavior.
Please perform the following to maintain the e-mail in the correct field:
- Copy the ID of the contact which does not have the e-mail address in the report.
- Go to the Account Management work center.
- Select the Contacts view.
- Search for the ID of the contact.
- Click Edit.
- Select General.
- Under the Personal Communication, maintain the e-mail address in the E-mail field.
- Click Save and Close.
Now the e-mail address will show as you reopen the report.
Keywords
Report, Sales Quote, Personal Communication, Sales Quote Volume - Extended, Contacts, Incorrect, Data , KBA , AP-CQP-CQ , Customer Quote , Problem