SAP Knowledge Base Article - Public

3391333 - The Items in the Sales Order Invoice Request are Displayed as "To be Invoiced" Even Though the Delivery status is Not Started

Symptom

When invoicing a Line Item with type Service - fixed price without actuals through a Sales Order Invoice Request you note that the status of the items are displayed as "To be invoiced", however in the Sales Order some of the Line Items are with Delivery Status as "Not Started" and the Service Status as "Not Released" while other Line Items have the Delivery Status as "Finished" and Service Status as "Released".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing Work Center.
  2. Go to the Invoice Requests View.
  3. Filter for All Invoice Requests.
  4. In the search field, search for the Sales Order ABC (where ABC represents the Sales Order ID).

All Items in the Sales Order Invoice Request document are displayed with status as "To Be Invoiced", even the ones which the Delivery status is displayed as "Not Started" in the Sales Order.

Cause

  1. Go to the Sales Order Work Center.
  2. Go to the Sales Order View.
  3. In the Search field, Search for the Sales Order ABC (where ABC represents the Sales Order ID).
  4. Navigate to the Items tab.

In the Sales Order document all line items are maintained with item type as Service - fixed price without actuals.

The reason this behavior occurs is because all Line Items initially had an Invoice Schedule maintained when the Sales Order was Released, however the Schedule Invoice dates were removed from the Sales Order soon after the document was released.

As the Sales Order Invoice Request was already created with all items when the Invoice Schedules were maintained in the document, the Line items will continue to be displayed in Sales Order Invoice Request but since there is no Invoice Schedule anymore, the items will be directly invoiced via the Sales Order Invoice Request.

Hence the status of the items will then change from "Not Relevant" to "To Be Invoiced".

Resolution

This is the system behavior for this scenario.

There are two available workarounds for this scenario:

First scenario: All line items are required to be invoiced in one Customer Invoice Document

In the case it is required to invoice all items in the Sales Order Invoice Request after the items are completely fulfilled.

The steps for this process would be:

  1. Go to the Sales Order Work Center.
  2. Go to the Sales Order View.
  3. In the Search field, search for the Sales Order ABC (where ABC represents the Sales Order ID).
  4. Navigate to the Items tab.
  5. Confirm that all line items are released to execution.
  6. Complete the execution to all Line items.
  7. Go to the Customer Invoicing Work Center.
  8. Go to the Invoice Requests View.
  9. Filter for All Invoice Requests.
  10. In the search field, Search for the Sales Order ABC (where ABC represents the Sales Order ID).
  11. Select Invoice button.
  12. Select Release button.

The Delivery Status will be displayed as "Finished", the Service Status as "Released" and the Invoice Status as "Finished" for all line items.

Second scenario: Not all line items are required to be invoiced in one Customer Invoice Document

In the case it is required to maintain a Reason for Rejection for the items with Delivery Status as "Not Started" in the Sales Order, so they are not available when the Sales Order Invoice Request is Invoiced.

  1. Go to the Sales Order Work Center.
  2. Go to the Sales Order View.
  3. In the Search field, search for the Sales Order ABC (where ABC represents the Sales Order ID).
  4. Navigate to the Items tab.
  5. Confirm the Line Items are Released to Execution.
  6. Complete the execution for the Line Items.
  7. Maintain a Reason for Rejection for the Line items that were not completed.
  8. Select Save.
  9. Go to the Customer Invoicing Work Center.
  10. Go to the Invoice Requests View.
  11. Filter for All Invoice Requests.
  12. In the search field, Search for the Sales Order ABC (where ABC represents the Sales Order ID).
  13. Select Invoice button.
  14. Select Release button.
  15. Open the Sales Order ABC again.
  16. Navigate to the Items tab.
  17. Remove the Reason for Rejection for the items.
  18. Select Save.

The items in the Sales Order Invoice Request will be displayed as "To be Invoiced" once the Reason for Rejection are removed, therefore they can be invoiced separately in the future.

Keywords

Service - fixed price without actuals, To be invoiced, Sales Order, Invoice Schedule Request, Sales Order Invoice Request, Not Started, No Released, items , KBA , SRD-CRM-INV , Customer Invoicing , How To

Product

SAP Business ByDesign all versions