SAP Knowledge Base Article - Public

3391801 - Error message is being received when trying to complete Payment Information during PDC - Onboarding

Symptom

  • The following error popped up when the onboardee filled in Payment Information and click the "Continue" button:
    • Error Message: "Looks like something went wrong. Please try again or contact Product Support, if the problem persists."
  • New Hire Template is being used with the PaymentInformation ConfigUI added as a section.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login as onboardee
  2. Fill in the necessary information in to Bank Information section
  3. Click "Continue"
  4. Error occurred

Cause

  • WorkFlow is getting triggered even though it has been disabled from all sections of onboarding
  • This happens when the PaymentInformation configUI is added to the first section on the Hire Template
    • The save fails from both candidate and admin login.

Resolution

  1. Configure a PaymentInformation ConfigUI to the New Hire Template:
  2. PaymentInformation could be successfully saved from Admin and Candidate login using the Standard Hire Template.
  3. Add the configuration UI to any other section on the template, the save of PaymentInformation would be successful.
  4. From the “Add New Employee” page, adding PaymentInfo to first section on Hire Template was successful when WF was triggered post submit.

See Also

3252143 - [Onboarding] Post declining the E-signature, Error throws up In PDC Step "Looks like something went wrong. Please try again or contact Product Support, if the problem persists."

Keywords

PDC Error, Payment Information error, New Hire Template, PaymentInformation ConfigUI, Payment Information, paymentInfo, PDC, Hire Template, Workflow, OBX, ONB, ONB2.0, Onboarding , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem

Product

SAP SuccessFactors Onboarding 2305