SAP Knowledge Base Article - Public

3391833 - You make changes in the Lead BO, however, when you save, you get the message: 'No changes detected; save not executed' 'Your entries have been saved'.

Symptom

You make changes in the Lead BO, however, when you save, you get the message: 'No changes detected; save not executed' 'Your entries have been saved'.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Go to Sales Workcenter.
  2. Go to Leads Workcenter view.
  3. Open any Lead.
  4. Click on Edit.
  5. Now, open the same Lead but in a different Browser or in Incognito Mode.
  6. Click on Edit.

The lead is editable, but when you click on save, you get: 

'No changes detected; save not executed'
'Your entries have been saved'.

Cause

1. The functionality of Save button is such that the messages we see are the result of clicking the Save button.

2. Even the name, status etc. fields is editable, but if object is locked, the save will not be executed on the database. 

Thus, even though, the save is not executed, in the UI, these fields are still editable.

Resolution

This is the current system behaviour.

Keywords

lead, locked, fields, editable, 'No changes detected; save not executed'
'Your entries have been saved'  , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer core applications all versions