Symptom
Phone call participant determination is different when created from an Activity.
Environment
SAP Cloud For Customer
Reproducing the Issue
Scenario 1:
- Go to Customers Workcenter.
- Open Individual Customer Workcenter view.
- In the OWL screen, search for any Individual customer which has a mobile number present.
- Click on the mobile number link.
- We can see that the Live Activity screen is opened.
- Enter the mandatory details and click Save.
- Open the Phone Call document created.
We can see that the Individual Customer is added as a line item in the Participants section of the Phone Call TI screen.
Scenario 2:
- Go to Customers Workcenter.
- Open Individual Customer Workcenter view.
- In the OWL screen, search for any Individual Customer and open the document.
- Click on the '+' icon.
- Select Phone Call.
- Enter the mandatory details, save and open.
- We can see that either no line item is seen or the 'Current User' is added as the Participant in the Participants section.
Cause
The Phone Call created as an Activity works different from Live Activity. The Phone Call activity determines the participant based on the determinations maintained in the Business Configuration for 'Call Participant'.
If no determination is maintained, no participant will be determined if Phone Call is created as an Activity. If 'Current User' determination is checked, then Current User will be added as the participant
However, if Phone call is done using Live Activity, the Individual Customer will be added as Participant
Resolution
This is the current system behaviour.
Keywords
call list, participant, determination, live activity, individual customer, mobile , KBA , LOD-CRM-TLS , Tele-sales , Problem