SAP Knowledge Base Article - Public

3391903 - Enterprise Search for Contacts does not query External ID of the Contact

Symptom

Enterprise Search for Contacts does not query External ID of the Contact

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Logon to C4C
  2. In the Homepage, click on Enterprise search on top of the screen
  3. Search for a Contact using Contact's External ID

Observation: No results are displayed

Cause

External ID is a parameter that is currently unavailable to be used as a query for Contacts or Partner Contacts under Enterprise search. External ID cannot be added as a field under Basic search or Advanced search in Enterprise search screen.

Thus, when you enter an External ID of a Contact in Enterprise Search, the expected Contact result is not displayed.

Resolution

This is the current system behaviour.

If you wish to request this functionality for the possible delivery in future releases, you can directly get in contact with the decision makers in SAP Product Management and request this functionality via https://influence.sap.com/sap/ino/#/campaign/1868  

Keywords

contact, external id, enterprise search, search, advanced, basic , KBA , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications all versions