Symptom
Searching for a Contact using External ID in Advanced Search Filter is giving different result than expected
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Customer Workcenter.
- Go to Contact Workcenter view.
- Click on Advanced Search Filter
- Enter the data in External ID field and Search.
The result External ID does not match with the External ID entered
Cause
An existing Contact might have more than one External ID. The Advanced Search Filter considers all External IDs. But, if you search in the External ID column in the OWL, the result will be shown based on the main External ID.
Resolution
This is the current system behaviour.
See Also
Keywords
contact, external id, search, owl, advanced search, filter , KBA , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , Problem
Product
SAP Cloud for Customer core applications all versions