Symptom
You are getting the Error: 'Quantity for line is less than minimum order quantity' in Opportunity
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Workcenter
- Go to Opportunities Workcenter view
- Open any Opportunity
- Go to Products Facet
- Add a product and enter the quantity less than minimum quantity defined for the product and save
- You see the Error: 'Quantity for line is less than minimum order quantity' in Opportunity
Observation: The Opportunity is still saved. The Opportunity Status can also be set to Won/Lost.
Cause
Not all errors are validation errors. Even though it is configured as an error message, the system will allow you to save the Opportunity. You would even be able to set the Opportunity Status to won/lost as well. Just that, when you open the Opportunity, the Error message will be visible.
Another Example of this would be, 'Use another sales organization.'. This is another error that will allow you to save the Opportunity.
Resolution
This is the expected standard system behaviour. If you wish to request this functionality for the possible delivery in future releases, you can directly get in contact with the decision makers in SAP Product Management and request this functionality via https://influence.sap.com/sap/ino/#/campaign/1868
Keywords
Quantity for line is less than minimum order quantity, opportunity, , KBA , LOD-CRM-OPP , Opportunity Management , Problem